fedora 14 下linux内核模块命令运行出错:安装软件包“module-init-tools”以提供命令“lsmod”? 事务失败: all-packages-already-installed, The packages are already all installed

fedora 14 下运行linux内核模块命令lsmod,出错,说没有该命令,需要安装,但运行安装命令又说命令已经安装,但lsmod就是还不能运行,如下:
command not found...
安装软件包“module-init-tools”以提供命令“lsmod”? [N/y] {输入y回车}
* 正在运行.. 事务失败: all-packages-already-installed, The packages are already all installed
yum install安装,提示说已经安装,于是yum reinstall,重新覆盖安装,得以解决。不过fedora14里,好像安装上的module-init-tools是fedora13版本里的包module-init-tools-3.11.1-2.fc13.i686 这并不影响使用

[root@fsc feng]# yum reinstall module-init-tools

----------------------------------------------------
以下是命令行输出,仅作参考

[root@fsc feng]# lsmod |grep 8169
bash: lsmod: command not found...
[root@fsc feng]# lsmod
bash: lsmod: command not found...
安装软件包“module-init-tools”以提供命令“lsmod”? [N/y]
* 正在运行.. 事务失败: all-packages-already-installed, The packages are already all installed

[root@fsc feng]# lsmod
bash: lsmod: command not found...
安装软件包“module-init-tools”以提供命令“lsmod”? [N/y]
* 正在运行.. 事务失败: all-packages-already-installed, The packages are already all installed

[root@fsc feng]# whereis lsmod
lsmod: /sbin/lsmod /usr/share/man/man8/lsmod.8.gz
[root@fsc feng]# yum install module-init-tools
已加载插件:langpacks, presto, refresh-packagekit
Adding zh_CN to language list
设置安装进程
包 module-init-tools-3.11.1-2.fc13.i686 已安装并且是最新版本
无须任何处理
[root@fsc feng]# yum reinstall module-init-tools
已加载插件:langpacks, presto, refresh-packagekit
Adding zh_CN to language list
设置覆盖安装进程
解决依赖关系
--> 执行事务检查
---> 软件包 module-init-tools.i686 0:3.11.1-2.fc13 将被 reinstalled
--> 完成依赖关系计算

依赖关系解决

================================================================================
软件包 架构 版本 仓库 大小
================================================================================
Reinstalling:
module-init-tools i686 3.11.1-2.fc13 fedora 412 k

事务概要
================================================================================
Reinstall 1 Package(s)

总下载量:412 k
Installed size: 939 k
确定吗?[y/N]:y
下载软件包:
Setting up and reading Presto delta metadata
Processing delta metadata
Package(s) data still to download: 412 k
module-init-tools-3.11.1-2.fc13.i686.rpm | 412 kB 00:07
运行 rpm_check_debug
执行事务测试
事务测试成功
执行事务
正在安装 : module-init-tools-3.11.1-2.fc13.i686 1/1

已安装:
module-init-tools.i686 0:3.11.1-2.fc13

完毕!
[root@fsc feng]# lsmod
Module Size Used by
vfat 6758 1
fat 38062 1 vfat
fuse 51544 9
ebtable_nat 1431 0
ebtables 12142 1 ebtable_nat
ipt_MASQUERADE 1765 3
iptable_nat 3945 1
nf_nat 16298 2 ipt_MASQUERADE,iptable_nat
bridge 57131 0
stp 1438 1 bridge
llc 3754 2 bridge,stp
deflate 1543 0
zlib_deflate 16199 1 deflate
ctr 2953 0
camellia 17759 0
cast5 15276 0
rmd160 6136 0
crypto_null 2142 0
ccm 6285 0
serpent 18049 0
blowfish 7246 0
twofish 5395 0
twofish_common 12658 1 twofish
xcbc 1991 0
cbc 2161 0
sha256_generic 11347 0
sha512_generic 6638 0
des_generic 15895 0
aes_i586 7138 0
geode_aes 4245 0
aes_generic 26460 1 aes_i586
ah6 4471 0
ah4 3939 0
esp6 3905 0
esp4 4104 0
xfrm4_mode_beet 1610 0
xfrm4_tunnel 1439 0
tunnel4 2005 1 xfrm4_tunnel
xfrm4_mode_tunnel 1418 0
xfrm4_mode_transport 981 0
xfrm6_mode_transport 1013 0
xfrm6_mode_ro 858 0
xfrm6_mode_beet 1423 0
xfrm6_mode_tunnel 1455 0
ipcomp 1585 0
ipcomp6 1602 0
xfrm_ipcomp 3353 2 ipcomp,ipcomp6
xfrm6_tunnel 3145 1 ipcomp6
tunnel6 1880 1 xfrm6_tunnel
af_key 22999 0
vmnet 35410 13
ppdev 6808 0
parport_pc 17897 0
parport 26215 2 ppdev,parport_pc
vmblock 9826 1
vsock 31975 0
vmci 45322 1 vsock
vmmon 58828 0
cpufreq_ondemand 7262 2
acpi_cpufreq 6285 0
mperf 1141 1 acpi_cpufreq
capi 10620 0
capifs 2374 2 capi
kernelcapi 28157 1 capi
ip6t_REJECT 3470 2
nf_conntrack_ipv6 14441 2
ip6table_filter 1207 1
ip6_tables 9929 1 ip6table_filter
ipv6 229581 45 ah6,esp6,xfrm6_mode_beet,xfrm6_mode_tunnel,ipcomp6,xfrm6_tunnel,tunnel6,ip6t_REJECT,nf_conntrack_ipv6
uinput 5228 0
snd_hda_codec_si3054 2988 1
snd_hda_codec_analog 53890 1
snd_hda_intel 20127 2
arc4 1085 2
snd_hda_codec 71701 3 snd_hda_codec_si3054,snd_hda_codec_analog,snd_hda_intel
snd_hwdep 4795 1 snd_hda_codec
ecb 1595 2
snd_seq 43447 0
snd_seq_device 5056 1 snd_seq
snd_pcm 61769 3 snd_hda_codec_si3054,snd_hda_intel,snd_hda_codec
gspca_vc032x 24940 0
gspca_main 19038 1 gspca_vc032x
r8169 31809 0
ath5k 143237 0
videodev 54469 1 gspca_main
snd_timer 15435 2 snd_seq,snd_pcm
snd 47365 13 snd_hda_codec_si3054,snd_hda_codec_analog,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_seq,snd_seq_device,snd_pcm,snd_timer
v4l1_compat 11390 1 videodev
mac80211 188648 1 ath5k
asus_laptop 12297 0
iTCO_wdt 8960 0
soundcore 5088 1 snd
iTCO_vendor_support 2070 1 iTCO_wdt
ath 7145 1 ath5k
snd_page_alloc 6180 2 snd_hda_intel,snd_pcm
cfg80211 110951 3 ath5k,mac80211,ath
r852 8298 0
sparse_keymap 2472 1 asus_laptop
serio_raw 3589 0
joydev 7306 0
mii 3578 1 r8169
sm_common 3104 1 r852
nand 28994 2 r852,sm_common
nand_ids 2730 1 nand
nand_ecc 3460 1 nand
mtd 15282 2 sm_common,nand
rfkill 13652 3 asus_laptop,cfg80211
microcode 11139 0
irda 87797 0
crc_ccitt 1237 1 irda
sdhci_pci 6246 0
sdhci 15685 1 sdhci_pci
firewire_ohci 17697 0
mmc_core 53202 1 sdhci
firewire_core 37873 1 firewire_ohci
crc_itu_t 1235 1 firewire_core
video 17730 0
output 1625 1 video
usb_storage 35519 0
radeon 556900 2
ttm 45014 1 radeon
drm_kms_helper 22278 1 radeon
drm 139288 4 radeon,ttm,drm_kms_helper
i2c_algo_bit 4197 1 radeon
i2c_core 21328 5 videodev,radeon,drm_kms_helper,drm,i2c_algo_bit
[root@fsc feng]# yum update module-init-tools
已加载插件:langpacks, presto, refresh-packagekit
Adding zh_CN to language list
设置更新进程
不升级任何软件包
[root@fsc feng]# modls |grep 8169
bash: modls: command not found...
[root@fsc feng]# lsmod |grep 8169
r8169 31809 0
mii 3578 1 r8169
[root@fsc feng]# modinfo r8169
filename: /lib/modules/2.6.35.10-74.fc14.i686/kernel/drivers/net/r8169.ko
version: 2.3LK-NAPI
license: GPL
description: RealTek RTL-8169 Gigabit Ethernet driver
author: Realtek and the Linux r8169 crew
srcversion: 922AC21C384AA7EE2321FEF
alias: pci:v00000001d00008168sv*sd00002410bc*sc*i*
alias: pci:v00001737d00001032sv*sd00000024bc*sc*i*
alias: pci:v000016ECd00000116sv*sd*bc*sc*i*
alias: pci:v00001259d0000C107sv*sd*bc*sc*i*
alias: pci:v00001186d00004300sv*sd*bc*sc*i*
alias: pci:v000010ECd00008169sv*sd*bc*sc*i*
alias: pci:v000010ECd00008168sv*sd*bc*sc*i*
alias: pci:v000010ECd00008167sv*sd*bc*sc*i*
alias: pci:v000010ECd00008136sv*sd*bc*sc*i*
alias: pci:v000010ECd00008129sv*sd*bc*sc*i*
depends: mii
vermagic: 2.6.35.10-74.fc14.i686 SMP mod_unload 686
parm: rx_copybreak:Copy breakpoint for copy-only-tiny-frames (int)
parm: use_dac:Enable PCI DAC. Unsafe on 32 bit PCI slot. (int)
parm: debug:Debug verbosity level (0=none, ..., 16=all) (int)
[root@fsc feng]#

关于“linux与windows”的帖子的一条回复

一次论坛回帖,当时感觉还有点意思,就复制在这里了。


2:更加人性化的界面设计,完善并简化3D功能(不是说复杂就是好,能用就行了,不要太花俏,搞得经常和软件或系统文件冲突就没必要了)
——linux的图型化界面以前比win差距不少,现在已经好多了,某些地方已经超越windows了;然而命令才是深入应用精准操作的本质

3:更合理的软件添加删除机制,傻瓜式的安装和操作才是时代发展的正确道路。是人用电脑不是电脑玩人
——yum,apt-get足够方便吧,连下载跟安装一步搞定,还防止下载到骗子软件

4:更精简的系统(现在的系统大多数都非常不精简,里面大多包括了NNNN基本不会用到的驱动和软件),如果能完全去掉这些,然后支持自由选择下载安装,那会更好。在这里也不得不提一下3D桌面
——linux驱动在内核里(或者内核模块里),如果有兴趣完全可以依照喜好与需要有选择的编译模块

5: 更好的错误修正机制(经常,有一点错误就是进不到系统,在底白字的类DOS界面不知所措。经常,一些软件的冲突,直接导致整个桌面系统的白屏。经常,一些 不知名的错误,导致了各种不知名的问题出现。有时,只不过小小的改一下config文件就能解决的鸡毛蒜皮错误,也直接进不到图形界面。这一切,都是失去 用户的基本问题)
当然第五点是最重要的,一个系统,不可能永远没有错误,关键是出现错误之后,修复错误的难易程度和几率。这一点,似乎还没有人提出过。
——稳定版一般很少现这种问题,当然不是不存在,出类似问题时,linux的表现确实与普通用户距离远了一点(出错消息太专业,一般人看了不知所措),这点需要进一步加强。

原帖地址 http://softbbs.pconline.com.cn/9457919_-1.html#post_94127846

fedora 14 Linux Kernel 2.6.35 下编译VMware workstation 7内核模块

新的Linux内核会导致VMware workstation重新编译部分组件,以保证调用正确的内核模块或函数接口,也即VMware workstation是部分依赖于内核的。如果内核版本过新,有可能会因VMware尚未为该版本开发出对应组件而导致workstation、 vmplayer等产品无法运行。

解决参考了Pario TechnoBlob的一篇帖子,脚本代码由Sputnick-Area(这里)获取。脚本为workstation 7.1.1编写,同时使用于workstation 7.1.1/2和随带的vmplayer 3.1.1/2。

解决步骤:

1. 下载并执行脚本:
cd /tmp
wget http://www.sputnick-area.net/scripts/vmware7.1.1-patch-kernel-2.6.35.bash
sudo chmod +x vmware7.1.1-patch-kernel-2.6.35.bash
sudo ./vmware7.1.1-patch-kernel-2.6.35.bash

2. 脚本执行完毕后会给出提示,要求执行如下命令。注意以超级用户身份执行:
vmware-modconfig --console --install-all

3.正常情况下执行过就可以了

参考 http://hi.baidu.com/thinkdifferent/blog/item/f6ec810a0da5bb31b1351d9d.html

海峰五笔 支持linux了/fedora14下已经成功安装

海线峰五笔 linux版/fedora14

海线峰五笔 linux版/fedora14

海峰五笔 支持linux了!

fedora14正式版正式发布已经有一段时间了,但是没有安装,直到昨天晚上很晚。今天使用时才发现没有五笔,于是安装,yum list查询五笔的包名,

[root@fsc /]# yum list *wubi*
已加载插件:langpacks, presto, refresh-packagekit
Adding zh_CN to language list
可安装的软件包
ibus-table-chinese-wubi-haifeng.noarch 1.3.0.20101206-1.fc14 updates
ibus-table-chinese-wubi-jidian.noarch 1.3.0.20101206-1.fc14 updates
scim-python-xingma-wubi.i686 0.1.13rc1-7.fc14 fedora

这不是一直以来很希望移植到linux里的海峰五笔吗!马上安装

[root@fsc /]# yum install ibus-table-chinese-wubi-haifeng.noarch

非常顺利,成功安装!

在此向海峰五笔及linux移植人员深表感激致敬,更向自由软件与自由精神致敬!!!

上海历史地图/上海历代地图-民国

民国三年 上海地图

民国三年 上海地图

民国五年 上海地图

民国五年 上海地图

民国十五年1926 上海地图

民国十五年1926 上海地图

民国淞沪商埠——民国十五年(1926年)上海地图

民国淞沪商埠——民国十五年(1926年)上海地图

民国上海特别市——民国十七年(1928年)上海地图

民国上海特别市——民国十七年(1928年)上海地图

民国三十三年(1944年)上海地图

民国三十三年(1944年)上海地图

民国上海市——民国三十七年(1948年)上海地图

民国上海市——民国三十七年(1948年)上海地图

民国上海市——民国三十七年(1948年)上海地图

民国上海市——民国三十七年(1948年)上海地图

Pages: 1 2 Next